Our E-Signature vendor, HelloSign, has notified us of an issue with signature requests.
Incident Report for Gigwell
Resolved
HelloSign has confirmed this issue is resolved.
Posted Mar 13, 2017 - 14:26 PDT
Identified
They have identified the issue and are working to resolve it.
Posted Mar 13, 2017 - 13:42 PDT