Amazon Web Services is experiencing a critical outage.
Incident Report for Gigwell
Resolved
Amazon has resolved the issue. Gigwell service is fully restored.

Please contact support@gigwell.com if you continue to experience issues.
Posted Feb 28, 2017 - 14:53 PST
Identified
Our service provider has confirm high error rates, has identified the issue and is working to restore normal operations. We are standing by to restore service as soon as they have resolved the issue.
Posted Feb 28, 2017 - 12:33 PST